How to set up SMTP configuration for community edition?

Hits: 1114

Please follow the steps:

Setp 1:

Go to the path in your application: app/Config/constants.php

Setp 2:

Set the following in Gmail SMTP:

define(“SMTP_HOST”, “ssl://smtp.gmail.com”);

define(“SMTP_PORT”, “465”);

define(“SMTP_UNAME”, “youremail@gmail.com”);

define(“SMTP_PWORD”, “******”);

Please provide your smtp username and password to configure your SMTP.

If you are finding problem after setting the username and password then please check the below:

Go to your php.ini file and enable the “php_openssl” in you PHP setting.

You need to enable extension=php_openssl.dll on php.ini file. If you are still facing the problem then the port 465 is not available. Try with 587 port.

Otherwise, Please contact with your server administrator.

Please run the following URL to check email is working or not:

http://DOMAINNAME/cron/test_email/?to=emailId

Example:

http://localhost/orangescrum/cron/test_email/?to=emailId (if you are using localhost)

http://127.0.0.1/orangescrum/cron/test_email/?to=emailId (if you are using IP)

http://myprojects.orangescrum.com/cron/test_email/?to=emailId (if you are using any valid domain)

If the email is not working then please follow the installation guide again.

Check gmail security issues here. Please see below links , you have to change some configuration at email end.

https://support.google.com/accounts/answer/6010255?hl=en

https://www.google.com/settings/security/lesssecureapps

Also check app/tmp/logs/os-email.log file for any error.

If you want to send emails to your internal server without authentication use the below code to get the following changes in place;

“Replace define(“EMAIL_DELIVERY”, “mail”); in place of define(“EMAIL_DELIVERY”, “smtp”); in constants.php app/Config/constants.php”

You can use PHPMailer add-on to set up SMTP on your server. Refer here to get the installation steps.

SMTP Email Configuration Issue:-

If it is not gmail configuration and you’re using either sendgrid or mandrill, then

  • open lib/cake/network/email/SmtpTransport.php – change the tls to true
  • open app/Controller/Component/SendgridComponent.php – add ‘tls’ => true to email config array in both sendgridSmtp and sendGridEmail functions

check the below url to check if email is working properly or not:

http://customersdomain.com/cron/test_email/?to=your_emailid  

Check SMTP Port: 

  • If ports(465,587) are not enabled, then open it.
  • Still mail functionality is not working then try with changing the ports to (465,587, 25)
  • If still it does not work:- in constants.php file remove the <> symbols from FROM_EMAIL in app/webroot/EmailReply.php
  • Add the hostname according to the mail server imap setting and Imap port. If ssl is enable then add novalidate-cert parameter to the host name.
  • Then Add HOST Name, User Name & Password

To Use Own Email Server: 

For own Email server: Add HOST_NAME, PORT, SMTP_UNAME, SMTP_PWORD in constant.php instead of gmail configuration

Incorrect authentication data error: 

  • Please double check the username and password.
  • If both are correct then check the server configuration. It’s some how blocking the server to connect to the mail server. We can not do anything to fix this.
  • Also make sure you’re not using 2 step verification and less secure app setting is ON.
Like(0)        Dislike(0)