Why my Quick Signup page is breaking after installation?

Hits: 553

It is either due to htaccess or file permission issue.

Sign up issue

  • Provide proper write permission to ” app/tmp “, ” app/webroot ” and ” app/Config ” folders and their sub folders. Provide either 777 or 755 permission to the mentioned folders.

If still you face the same issue, then check your htaccess permission.

To enable htaccess in CentOS server

Under DocumentRoot “/var/www/html

Change Require all denied to Require all granted

DocumentRoot “/var/www/html”

#

# Relax access to content within /var/www.

#

<Directory “/var/www”>

   AllowOverride None

   # Allow open access:

   Require all granted

</Directory>

# Further relax access to the default document root:

<Directory “/var/www/html”>

  #

   # Possible values for the Options directive are “None”, “All”,

   # or any combination of:

   #   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews

   #

   # Note that “MultiViews” must be named *explicitly* — “Options All”

   # doesn’t give it to you.

   #

   # The Options directive is both complicated and important.  Please see

   # http://httpd.apache.org/docs/2.4/mod/core.html#options

   # for more information.

   #

   Options Indexes FollowSymLinks

#

   # AllowOverride controls what directives may be placed in .htaccess files.

   # It can be “All”, “None”, or any combination of the keywords:

   #   Options FileInfo AuthConfig Limit

   #

   AllowOverride None

#

   # Controls who can get stuff from this server.

   #

   Require all granted

</Directory>

htaccess Issue on Centos/Fedora :-

=========================

Change

AllowOverride None

           To

AllowOverride All

In apache main Configuration File(/etc/httpd/conf/httpd.conf)

 

htaccess Issue on Ubuntu :-

====================

Add

# Require all granted

On Apache main configuration File Under <Directory>

                                                                 DocumentRoot /var/www/html

                                                                 Require all granted

                                                                </Directory>

ERROR 500 Or External Server Error/htaccess header issue on WAMP SERVER

Uncomment the line in apache configuration file :=

in apache->httpd.conf:=

<IfModule mod_headers.c> Header set [your_options] </IfModule>

                                  OR

Left click on Wampserver and select apache=>apache modules=>select header modules to enable it

and at last restart WAMP server.

htaccess Issues on WAMP Server :-

STEP  1:  click on Wampserver and select apache->httpd.conf

STEP  2: Find and replace the following text

Find      #LoadModule rewrite_module modules/mod_rewrite.so

Replace   LoadModule rewrite_module modules/mod_rewrite.so

STEP  3: Restart Wamp Server

  OR

Left click on Wampserver and select apache=>apache modules=>select rewrite modules to enable it

and at last restart WAMP server.

To enable htaccess for IIS server

Please check the web.config file. We don’t have any document for IIS server right now.

 

Like(0)        Dislike(0)